Menu

Excel: Calcolo turni e gestione calendario – 05 – Giorni settimana in automatico

25 luglio 2016 - Excel

Excel: Calcolo turni e gestione calendario – 04 – Definire mese e anno da menu a tendina

Ora vedremo come fare in modo che i giorni della settimana vengano gestiti in modo automatico in base al mese ed anno che abbiamo messo nel menù a tendina.

Iniziamo con concatenare giorno mese anno prendendo il giorno dalla prima riga, mese e anno dalla cella del menù a tendina

 

2016.07.24-10:43:49Spazio di lavoro 1

=Concatena(A,B;C….) Concatena accetta sia riferimenti a celle sia testo purché compreso tra virgolette “.

Dobbiamo concatenare aggiungendo il separatore usato da excel per le date altrimenti otterremo 1Gennaio2016 mentre il risultato da ottenere è 1/Gennaio/2016. Per fare ciò basta aggiungere “/” in mezzo alle celle nella formula

La formula sarebbe =Concatena(E1;”/”;B1;”/”;B2)

2016.07.24-10:44:54Spazio di lavoro 1

Ho scritto sarebbe perché dobbiamo trascinarla e quindi trascinando la cella E3 verso destra anche tutti i riferimenti all’interno della formula verranno spostati verso destra e ciò va bene per i giorni ma non per mese ed anno quindi dobbiamo aggiungere il simbolo del dollaro nella colonna del mese e dell’anno.

=Concatena(E1;”/”;$B1;”/”;$B2)

2016.07.24-10:45:54Spazio di lavoro 1

Ora possiamo trascinare E3 verso destra fino al giorno 31

2016.07.24-10:50:03Spazio di lavoro 1

Mi rendo conto che elenchi e tendine andrebbero spostate perchè nel momento in cui nascondessi le prime righe del foglio nasconderei elenco e menù a tendina. Quindi seleziono gli elenchi dei mesi e degli anni e li sposto a partire da AS8

2016.07.24-10:46:54Spazio di lavoro 1

Così facendo gli elenchi saranno in linea con la tabella dei turni anche se in futuro nasconderemo le colonne degli elenchi non avremo parti nascoste perchè dalla riga 8 in poi non nasconderemo nulla.

2016.07.24-10:47:22Spazio di lavoro 1

 

2016.07.24-11:01:09Spazio di lavoro 1

 

2016.07.24-11:01:13Spazio di lavoro 1

Ora che abbiamo i giorni della settimana in forma numerica da 1 a 7 dobbiamo trasformarli nelle lettere iniziali del giorno. Ci sono più modi per farlo, usando il cerca.vert, nella versione 2016 e online di office con la funzione Più.se o con la più ampiamente compatibile formula se.

Nella versione 2016 ed online di Office si potrebbe fare così

=PIÙ.SE(E4=1;”D”;E4=2;”L”E4=3;”M”E4=4;”M”E4=5;”G”E4=6;”V”E4=7;”S”)

Nella versione 2010 di excel

=SE(E4=1;”D”;SE(E4=2;”L”;SE(E4=3;”M”;SE(E4=4;”M”;SE(E4=5;”G”;SE(E4=6;”V”;SE(E4=7;”S”;””)))))))

Nella versione 2003 non funziona il se con più di 6 nidificazioni. Per farne 7 bisogna ricorrere ad un & nel mezzo della formula in modo da spezzarla. In questo esempio la prima parte della formula ha 4 SE nidificati, dopo “& SE” ho inserito i rimanenti 3

=SE(E4=1;”D”;SE(E4=2;”L”;SE(E4=3;”M”;SE(E4=4;”M”;””)))) & SE(E4=5;”G”;SE(E4=6;”V”;SE(E4=7;”S”;””)))

2016.07.24-10:58:46Spazio di lavoro 1

Ora possiamo trascinare questa formula da E9 fino al giorno 31 quindi fino a AI9

2016.07.24-10:58:55Spazio di lavoro 1

A questo punto sia il giorno della settimana sia l’evidenziazione variano col variare del mese e dell’anno

2016.07.25-17:05:36Spazio di lavoro 1

 

2016.07.25-17:09:26Spazio di lavoro 1

2016.07.25-17:09:39Spazio di lavoro 1

 

Alla prossima puntata vedremo come non visualizzare i giorni come ad esempio febbraio o i mesi che ne hanno solo 30

Excel: Calcolo turni e gestione calendario – 06 – Nascondere in automatico i valori del mese con 28, 29, 30 giorni

 

2 pensieri su “Excel: Calcolo turni e gestione calendario – 05 – Giorni settimana in automatico

  • Pingback: Excel: Calcolo turni e gestione calendario – 04 – Definire mese e anno da menu a tendina | Eris Magagnin

  • Pingback: Excel: Calcolo turni e gestione calendario – 06- Nascondere in automatico i valori del mese con 28, 29, 30 giorni | Eris Magagnin

  • Lascia un commento